FANDOM


You'll be carrying out photometry in AstroImageJ. Check the tutorials for more information.

Before you start, make sure your raw data have been corrected for bias, dark, and flat effects. You can check this by going into the raw_data directory and looking for the pipelineout folder. The corrected images should live in this folder. Look at one or two images and make sure that there are no flat field artifacts apparent in the image(s).

  1. Go to the menu in the AstroImageJ and select File—> Import—> Image Sequence..
    • Choose the folder in which your calibrated images are located (this is the pipelineout folder discussed above).
    • Select "Open". A window which is called “Sequence Options” will pop up.
    • Make sure you activate the “sort names numerically” and “use virtual stack” options.
    • Also make sure you have the appropriate number of images in the first "Number of Images" blank.
    • Select "OK".
  2. You've now opened a sequence of images in an image window. You'll want to measure the seeing, by measuring the FWHM of bright (not saturated!) stars in a few images. Click on a star, and then go to 'Analyze > Plot seeing profile' (instead, you can click the mouse on a star while holding down the 'Alt' button). You should get a plot that looks like a half bell curve, and the FWHM should be given at the top. Click on a few additional stars, and repeat on a few additional images, to get a sense of the range of FWHM. FWHM is in units of pixels.
  3. In the image window, select the cyan/red icon with a bullseye that says "Set" and is called Change aperture settings.
    • Under "radius of object aperture", enter 25 (this in units of pixels).
    • Set "inner radius of background annulus" to 40.
    • Set the "outer radius of background annulus" to 65.
    • Set CCD gain [e-/count] to 1.5, CCD readout noise [e-] to 9.0, and CCD dark current noise [e-/pixel/sec] to 0.40.
  4. Once the images are loaded, they will display in a pop-up window.
    • Go to Process—> Align stack using WCS or apertures. The "Stack aligner” window will pop up.
    • Make sure that 'First Slice' is image #1, and 'Last Slice' is the total number of images in your image stack.
    • Make sure you ONLY activate the option  “Show help panel during aperture selection” (deselect any other options that might be checked). Press “ok”.
    • Go back to the window displaying your image, and left-click your mouse button on 2--3 stars. Then push Enter. The alignment will start, and a successful run should produce a message that says "Virtual stack alignment complete". Your new aligned images will be saved automatically in a subfolder which is called "aligned"; the subfolder is located inside the calibrated images folder (i.e., directory pipelineout).
  5. If you have get an error when you try to align the stack, return to Step 2 and try making the radius of the apertures and annuli larger.
  6. Now you need to import your aligned images, in the same way as described in Step 1, selecting the 'aligned' folder.
  7. Make a seeing profile:
    • In the window displaying your image, click on any star that is not saturated.
    • Go to Analyze -> Plot seeing profile. You should get a radial profile of the star's brightness.
    • Note the FWHM (this is units of pixels); it is noted at the top of the Seeing Profile window.
  8. Now choose the icon box with the two circles which is called Perform multi-aperture photometry. The “Multi-Aperture Measurements” window will pop up.
    • As the "radius of object aperture", give the FWHM.
    • Give something roughly twice the FWHM as the "inner radius of background annulus", and something roughly three times the FWHM as the outer background radius.
    • Please enable: “Reposition aperture to object centroid” and "Show help panel during aperture selection”.
    • Disable other options that might be clicked.
    • On the bottom of the same window you may find the "Aperture Settings” button. Click on it to make sure "List the following FITS keyword decimal values in measurements table” is activated.
    • You may also want to click on the “More Settings”. There you can find the information that will be stored in your photometry table (I would recommend to mark all of them! We may use them for later checks).
    • Click "OK" on the settings windowns.
    • Then click "Place Apertures" in the "multi-aperture measurements" window.
    • Click on your target first. Then choose 3--4 comparison stars. Click on them.
    • Then push Enter.
  9. The "measurements" table should pop up with lots and lots of columns, and with one row per image. Now you need to save this table by going to File > Save As. Pick an image name and save it in your aligned directory.
  10. Now, it's time to plot! You can plot the data you just saved with your favorite plotting software, like Python or Excel---or continue on in AstroImageJ (directions below). The columns you most care about are JD_UTC (which is the observing time of each image, in units of Julian Date and UT), and Source-Sky_T1 (which is the number of counts attributable to your target star, after sky subraction). You'll also want to plot the comparison stars to make sure they are not varying in the same way as yorur source. Ideally, the comparison sources look rock steady while your science target may vary.
  11. If plotting in AstroImageJ:
    • Select the multi-plot tool by finding the AstroImageJ icon that looks like a red and white squiggly, called Multiplot (two to the left of the DP icon). It will open two windows, the "Multi-plot main" and "Multi-plot Y-data" windows.
    • In the "Multi-plot main" window, go to File > Open Table and select the file you saved at step 7. Select "Open". Several more windows will pop up, take them in stride for the moment.
    • In the multi-plot main window, select "JD_UTC" from the "Default X data" drop down menu. The 'Y-datasets' should now be set to the number of images you analyzed.
    • You can set things like plot title and axis labels if you like.
    • Go to multi-plot y-data window, under Data Set 1 (first row), select "plot" and "auto-scale". Under "x-data" should be "default". Select under "y-data" from the dropdown menu "Source-Sky_T1". This will by default plot counts (not magnitudes).
    • If you click "auto error", the plot routine is smart enough to find the relevant error column and plot it as error bars.
    • Under "Norm/Mag Ref", select "none".
    • The plot should automatically update as you select these options. If it doesn't, in the 'multi-plot main' window, there is a 'redraw plot' button at bottom right.
    • You can press 'save' in the 'plot of measurements' window to save the plot.

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.